Koodo Community

Community

Solved

I added on the international plan for 50 texts, voice calls and data, but I'm here in Thailand now and it's not working....help me! .


I added on the international plan for 50 texts, 50 voice calls and 50MG of data, but I'm here in Thailand now and it's not working....help me! I'm not sure what's up.

12 replies

Userlevel 7
Badge +4
You need to go on self serve and add the free international voice roaming add on and international data roaming
Userlevel 7
Also just out of curiosity, which phone do you have? I'm not sure what frequencies the providers in Thailand use but your phone needs to support those to connect to them.
Userlevel 7
Badge +4
When did you add it Jamie-Marie? And how? It seems you have added the International Long Distance saver to your account a week ago. You do not have the roaming add-on. Pls add it and things should be working fine.
Thank you! I went on my account and I did add it, but it is saying I need to activate it by texting ALL40 to 7626, but I'm not able to text here! Before I came I thought adding it meant activating it. Do you know if there is another way to activate it or something that can be alternatively done?
Userlevel 7
Badge +4
Jamie Munro wrote:

Thank you! I went on my account and I did add it, but it is saying I need to activate it by texti...

Yo should be able to text. Have you tried? You can add it through the Koodo app too. 
Jamie Munro wrote:

Thank you! I went on my account and I did add it, but it is saying I need to activate it by texti...

Yes I've tried and it won't go through. It says I have no service so I'm just confused why it isn't working for me. Was it properly activated?
Userlevel 7
Badge +4
Jamie Munro wrote:

Thank you! I went on my account and I did add it, but it is saying I need to activate it by texti...

You did go into self-serve and add the international roaming add-ons, right? The free ones Robert mentioned as th first reply? If after that it still isn't working, go into your network settings and switch to manual. Give I 1-2 minutes to populate the list. See wha pops up and what you can connect to for 3G. If you can connect to any of them then you should be able to send the text. http://help.koodomobile.com/coverage-long-distance-and-travelling/Travelling Select hspa and Thailand and those should be the networks to attempt.
Userlevel 7
Badge +4
Jamie Munro wrote:

Thank you! I went on my account and I did add it, but it is saying I need to activate it by texti...

Do you see any bars on your phone indicating that you have network coverage? If no, and you have no service at all make sure your phone hasn't accidentally been left on airplane mode or your settings are not turned off for roaming.
Jamie Munro wrote:

Thank you! I went on my account and I did add it, but it is saying I need to activate it by texti...

I have full bars for network coverage and it for sure is off airplane mode, but when I go to send a text it says I have no mobile service. I'm unable to use my data either. From what I see I have roaming on, but once I have it on and I am unable to text or connect to data, I turn it off to avoid extra fees. I'm worried my plan wasn't activated even though I added it
Userlevel 7
Badge +4
Jamie Munro wrote:

Thank you! I went on my account and I did add it, but it is saying I need to activate it by texti...

Hmmmm....I see activity on your account (text, data) up until Aug 2nd. So thphone was working at that point. What date did you land in Bangkok?
Jamie Munro wrote:

Thank you! I went on my account and I did add it, but it is saying I need to activate it by texti...

I landed Aug 3rd evening. I had data at the airport in Toronto and then once I landed I didn't have it anymore.
Any luck on using phone out of country

Reply