Koodo Community

How do I keep track of my bill self serve don't work

  • 16 January 2016
  • 6 replies


6 replies

Userlevel 7
Badge +4
What do you mean you "self serve don't work"?
Can you login?
You can login, but they don't allow you to check your bill?

If you register your self serve and didn't work, you'll need to call in.
*611 from your Koodo phone and tell them you have difficulty to use self serve. They will help you.
Userlevel 3
Hello Cheyenne! Were you finally able to log into your Self-Serve account? Keep us posted! 
Userlevel 5
Its possible that when the emal address was set up it was entered incorrectly....by koodo agent (i know i made a mistake like this). Sometimes it is best to call koodo and make sure your info is correct, and if you cant login could have them reset pwd. Always best to do this on computer and then double check on phone. That way one phone call takes care of all problems
I'm having the same problem, and when I call *611 I just get stuck in a phone loop with no people.  Does anyone know which options will take me to a live person to solve this problem?  AND, by chance, do you know if this will incur me a service charge.  I didn't know there is no free customer service?  I just signed up today and I can't even get my service working.  Surely they have to help me do this, at least, for free?


Userlevel 7
Badge +4
I'm having the same problem, and when I call *611 I just get stuck in a phone loop with no people...Can you login?  What error message you get?
Have you register for self serve and  validate your email ?

When you call *611, you can choose option 6 for technical support or option 5 for customer service. and keep pressing 0 if you don't know which option to pick.

They never charge you for technical support and/or asking questions.
You will be charged if you ask them to do something that you can do on self serve. But, sometimes system doesn't work well or doesn't allow you to change things through self serve. Then they won't charge you in those cases too.
I'm having the same problem, and when I call *611 I just get stuck in a phone loop with no people...I have tried to register, and validate my email, but it's not working.  So I tried again with a second email address, not the one I gave when I purchased the phones.  I got this error:

[b]Unable to process request Unable to process request
[b] [b]Our site is currently experiencing technical difficulties, so we are unable to process your request at this time.
[b] [b]Please try again later.
[b] [b]To regain account access, call us at 1-866-99-KOODO (1-866-995-6636) or *611 from your mobile phone.
[b]It's a free call.

Now whenever I try to reset my password and log in it locks me out for 30 minutes.  I need to speak to someone for sure.  It's a circle and nothing is working.  I'm glad they won't charge me in these cases?  I would hope not....  ??

Thank you!