Koodo Community

Community

Solved

Help. Samsung shows bars but will not connect to koodo.


I have a Samsung Fascinate T959P, and it shows connectivity bars at the top (by battery status), but will do nothing.  An attempted phone call gets "Not registered on network" error message. 

It's complicated. 

I recently got an unlock code because this phone was locked to Telus.  The first time I turned it on with Koodo sim in, I entered the NCK code and it said successful.  But it still said no service.  The next time I rebooted with Koodo sim in, it prompted for NCK code again, and this time was unsuccessful.  I hit dismiss after that, not wanting to use up my attempts.

However, if I power up with no sim in, then insert the Koodo sim, I get the bars at the top.  The menu screen says there's no sim card, but there's the bars.  I can't make calls or  texts though.
I have tried factory reset, and tried to add VPN, but I can't access what matters-the APN, because Settings/Mobile Networks gets "Insert SIm card to access network services" error msg.

Arrgh!  I'm two weeks without a phone now and don't have access to another phone to call Koodo.  Losing. Mind.

The situation is similar to this one,
https://community.koodomobile.com/koodo/topics/samsung_galaxy_s3_not_registered_on_network
which does not tell how it got resolved (but shows Issue is not with sim card)

Incidentally, I have contacted Telus and confirmed that the phone is NOT stolen, and is unlockable, although I paid somewhat less online for my code than Telus' $50.
Koodo said the Sim is good and "should work if you just put it in an unlocked phone".

2 replies

Userlevel 7
I don't think the phone is actually unlocked. Once a phone is unlocked, it will never ask you for the unlock code again so that's fishy already. I'd make sure you have the correct code
Fair enough.  Unlockbase wants "video evidence" that code isn't working to refund me, so that will be a long rigamarole.  Super complicated even to pay Telus their $50.  This will take a while.

Reply