Koodo Community

Community

Solved

Help! Cant get data/internet to work on LG V20 unlocked. Urgent!


Data wont work on my lg V 20, it is unlocked. Tried adding APN and it just wont work, no H or LTE will come up on bars. Can send text and make calls. Help very appreciated! 

19 replies

Userlevel 7
Badge +4
Hello Hugh, 

What's the version of the V20 you have?

Here's a list : https://www.techwalls.com/lg-v20-model-numbers-differences/
Userlevel 7
Data on? No data block listed on your plan add ons in self serve? Can you post screen shots of your APN settings?
From checking it is a V20 H990DS. Im from Australia and currently working near Lethbridge, got the plan today. its an $80 plan with 3gb, no data block I can see.

Userlevel 7
Hugh Macague wrote:

From checking it is a V20 H990DS. Im from Australia and currently working near Lethbridge, g...

Your signal strength is extremely low from what I can see. That may be causing you to not be able to connect to data. Try swapping sim positions and see if your signal is any better. Also make sure the koodo sim is selected for data.
Hugh Macague wrote:

From checking it is a V20 H990DS. Im from Australia and currently working near Lethbridge, g...

There we go! was obvious now i see. Was getting to technical, was just the data card selected. thanks!
Userlevel 7
Hugh Macague wrote:

From checking it is a V20 H990DS. Im from Australia and currently working near Lethbridge, g...

Great. Enjoy your excellent phone!
Hugh Macague wrote:

From checking it is a V20 H990DS. Im from Australia and currently working near Lethbridge, g...

Im having the same problem can yal help me
Userlevel 7
Badge +4
Hugh Macague wrote:

From checking it is a V20 H990DS. Im from Australia and currently working near Lethbridge, g...

If the same thing did you try the things said here to try? What phone do you have etc?
Hugh Macague wrote:

From checking it is a V20 H990DS. Im from Australia and currently working near Lethbridge, g...

I have an lg v20 version is 7.0 And no no really phone sabe dont know what to do
Hugh Macague wrote:

From checking it is a V20 H990DS. Im from Australia and currently working near Lethbridge, g...

Hugh Macague wrote:

From checking it is a V20 H990DS. Im from Australia and currently working near Lethbridge, g...

My phone say it has no Apn does that have anything to do with it ???
Userlevel 7
Hugh Macague wrote:

From checking it is a V20 H990DS. Im from Australia and currently working near Lethbridge, g...

Yes, you'll need to setup your APN to use data.

Use the settings shown above by Huges Also I see that you're roaming, where are you? Do you have a Koodo easy roaming enabled?
Hugh Macague wrote:

From checking it is a V20 H990DS. Im from Australia and currently working near Lethbridge, g...

Im in california but have a mexico carrier telcel . but i tried putting a at&t and still wouldnt work. Let me figuer out how to make it like huges
Userlevel 7
Hugh Macague wrote:

From checking it is a V20 H990DS. Im from Australia and currently working near Lethbridge, g...

Okay you need to enter the APN for your Mexican carrier. Link to telcel APN instructions http://www.cosmovil.com/2016/10/confi...
Hugh Macague wrote:

From checking it is a V20 H990DS. Im from Australia and currently working near Lethbridge, g...

Omg it worked !!!thank you soo much for yals guyes help .!!!yal rock
Hugh Macague wrote:

From checking it is a V20 H990DS. Im from Australia and currently working near Lethbridge, g...

One last question if i switch to at&t do i have to change the apn
Userlevel 7
Badge +4
Hugh Macague wrote:

From checking it is a V20 H990DS. Im from Australia and currently working near Lethbridge, g...

Usually when you put in a different SIM card it will automatically set the apn for you but if it doesn't then yes, you will.
Hugh Macague wrote:

From checking it is a V20 H990DS. Im from Australia and currently working near Lethbridge, g...

Okay thank yu
Userlevel 7
Hugh Macague wrote:

From checking it is a V20 H990DS. Im from Australia and currently working near Lethbridge, g...

Enjoy your trip, glad we could help.

Reply