Koodo Community

Community

Solved

Google Play Store - Error retrieving information from server RPC:S-5:AEC-0


Badge +4
Is anyone else having difficulty with Google's Play Store? [i](I couldn't post this as a problem, so I've opted to post this as a question followed by the answer). This error may appear on some Android devices and prevents users from upgrading or downloading new apps. I found that by downgrading to an earlier version of Play Store, solved the problem. Here's how to do it: Go to: Settings > Application manager > swipe to the left until the ALL tab is visible. Scroll down to and tap Google Play Store, at the top of the page, tap the box labelled Uninstall updates. Reboot the device and Google Play will revert back to the earliest version, in my case it's 3.10.10. The previous version was 4.1.10. After a couple of updates or app downloads, Play Store automatically reverts back to 4.1.10 and everything works flawlessly again. Again, this probably isn't happening on every Android device out there, but if someone should encounter this error, this is a tried and true method to get you back up and running on Play Store.

5 replies

Userlevel 7
Glad you found a fix! Thanks for sharing!
Userlevel 1
Chad Burr wrote:

Glad you found a fix! Thanks for sharing!

This found fix on android forum may also help to get rid of this annoying error:Tap APPS/PlayStore tap MENU button (to the left of your home button) The popup menu has HELP at the bottom. Tap HELP. Scroll down and search "troubleshooting download issues" Read and follow instructions. Or, you could do what I do: Settings/Storage/UNMOUNT SD card and then MOUNT SD card. That fixes it for me, the two times it's happened. When all else fails, read the Help menu of Google Play Store and follow directions,
Userlevel 6
Thanks a lot rikkster! Great job 🙂 ________________________ If you see a good answer, give it a star.
Userlevel 6
You don't need to reboot. An easier fix is to clear the App Data from: -Google Services Framework -Google Play Store and uninstall updates for Google Play Store
http://firstandgeek.com/solved-error-retrieving-information-server-google-play-store describes very well about this issue.

Reply