Koodo Community

Community

Solved

Galaxy S7 works slowly and drops on wifi and lte


My galaxy S7 sucks as far as making what's app of Facebook calls they drop etc. Glad u didn't sell my S4 of use that to get a good connection. Be returning my S7 not worth it at all!!

12 replies

Userlevel 7
Badge +4
Hi Bradley, im having a hard time making out the whole problem your having. Could you explain that again .
Userlevel 7
Badge +4
When did you buy your S7? Is it within 15 days?
http://help.koodomobile.com/getting-started-with-koodo/before-you-purchase/what-is-your-15-day-money...
Mayumi wrote:

When did you buy your S7? Is it within 15 days?
[url=http://help.koodomobile.com/getting-started-...

Yes
Userlevel 7
Badge +4
Have you tried a factory reset and clearing your system cache after making sure it's updated to the most recent version of Android available for the device at the moment
Not factory reset no. Buy up to dress and cleared cashe. Anyway online had the phone for a few days
I meant updated not up to our dress that's auto correct for ya
My s7 edge was going wonky after a update, kept turning off the WiFi setting or it would stay connected to a WiFi even thought I wasn't in range ... I had to clear my WiFi settings.
How do I do that ?
Userlevel 7
Badge +4
Bradley Ryver Steffensen wrote:

How do I do that ?

Look at #6: http://www.androidauthority.com/galaxy-s7-galaxy-s7-edge-problems-fixes-682958/
Badge +4
Bradley Ryver Steffensen wrote:

How do I do that ?

'Forget' the Wi-Fi connection. Go to: Settings > Wi-Fi - press and hold the connection you want, then selecting “Forget”. Re-enter the password and try again. Go into the Advanced settings in the Wi-Fi menu of the phone, and look for Wi-Fi frequency band. Change it from the default automatic selection to 2.4 GHz only. Go into Wi-Fi > Settings > Advanced; make a note of your device MAC address, then make sure that the phone is allowed access in the router’s MAC filter. LTE - try selecting a different network type. HSPA+/UMTS or WCDMA only, whichever is displayed, either selection will work and should improve signal reception. To change network types go to: Settings > More > Cellular networks > Preferred network type and make the selection there.
Userlevel 5
Hey Bradley! Did everyone's suggestions help? Keep us posted!
No I'm gonna go to the store when I have gone may bring phone back. Way to frustrated

Reply