Koodo Community

Community

Solved

Galaxy S3 WIFI disconnects without warning


I'm very disappointed with my Galaxy S3 for the past few months.  I only have 500 MB of data so I ensure I'm connected to WIFI as soon as I get home or before I do any major surfing or app sessions.  As of late, the WIFI disconnects randomly without warning and it's not until my phone alerts me that I've used 50% of my data that I realize it is off.  What is going on with my phone?  It never did this before.

Router is a dlink and is very reliable.  Spouses BlackBerry never has issues, or our laptops or PC.  My phone is up to date.  Does the S3 have a bad antenna or something?

Thanks in advance.

12 replies

Userlevel 7
Badge +4
Go into settings than WiFi. Click on ur connection and click forget. Than re enter ur password. This may help establish a new fresh connection
Chadwick wrote:

Go into settings than WiFi. Click on ur connection and click forget. Than re enter ur password. T...

Done that every time this happens.  I've even done a complete reset on the router a couple times.
Userlevel 7
Badge +4
Chadwick wrote:

Go into settings than WiFi. Click on ur connection and click forget. Than re enter ur password. T...

The S3 is notorious for crapping out even more than phones normally do after a fe years. Or sooner. You could try flashing with CM if it'll make the difference if it's a software issue. Although you should first try a factory reset and back up your data first. I'd personally cut my losses an upgrade to anything else really.
Chadwick wrote:

Go into settings than WiFi. Click on ur connection and click forget. Than re enter ur password. T...

Guess I'll try a fresh install next.  
Thanks
Chadwick wrote:

Go into settings than WiFi. Click on ur connection and click forget. Than re enter ur password. T...

Plan is for both of us to get new phones next spring.  Just need to be sure we get phones from companies that don't abandon them after 6 months.
Userlevel 7
Badge +4
Chadwick wrote:

Go into settings than WiFi. Click on ur connection and click forget. Than re enter ur password. T...

Motorola is one of the best. Who knows now with Lenovo though. Samsung is expensive but eventually upgrades. Sony is generally the same. But their mid range phones are decent. If you're not looking for a flagship I'd go Motorola. Asus switching to Qualcomm chip sets might mean that they will finally have decent upgrades with the upcoming žena one 3 line up. There's Xiaomi who might be in the NA market by next spring. Hope the S3 holds out until then.
Userlevel 7
Badge +4
You could do what I do and only turn on your data connection when you need it to avoid unwanted usage, as soon as I'm connected to wifi I disable the data connection with a quick tap in the quick settings of the notification shade and no more worries.
Paul "Kid Android" Deschamps wrote:

You could do what I do and only turn on your data connection when you need it to avoid unwanted u...

unfortunately when I have the data off, MMS no longer works.  I use picture messaging quite a bit.
Userlevel 7
Badge +4
Paul "Kid Android" Deschamps wrote:

You could do what I do and only turn on your data connection when you need it to avoid unwanted u...

Yeah I turn it on just to send / recieve mms then right back off, it's a piece of mind thing and worth the extra second to do when you have such limited data we get from Canadian carriers. Definitely not an ideal solution through as your device should stay connected to wifi if commanded to. Do you have the wifi connection set to stay enabled even when the device sleeps?
Userlevel 4
I am surprised about some of these comments. I had a S3 for three years and I never had any problem at all, it was one of the best phones I ever had. Now I gave the S3 to somebody else who is still using it without problems. On the other hand I am not very happy with the Dlink that will be replaced very soon.
Userlevel 7
Badge +4
Tiz wrote:

I am surprised about some of these comments. I had a S3 for three years and I never had any probl...

it's not often I hear of S3's without issues but it's very hard to find 100% failure rates. I absolutely believe that you got lucky. Someone has to.
Badge +4
You can make your S3 a preferred device on your DLink router using the MAC address filter option. Login to the router and click on the Advanced tab. Select Network Filter. Click on the dropdown menu and select 'Turn MAC filtering ON and ALLOW computers listed to access the network'. Enter the phones' Wi-Fi MAC address into an empty box and make sure to click the 'save' button when finished. The phones' Wi-Fi MAC address is found in Settings > About Phone > Status - scroll down to find the Wi-Fi MAC address. The above method ensures a dedicated connection between your S3 and your router. I've been using this method for years with all my phones and without issue.

Reply