Koodo Community

Community

Solved

Galaxy s2 firmware upgrade is not supported via kies


i just bought a galaxy s2 today and when i connected it to kies it says "Your devices current firmware version is not supported to update firmware via kies" My firmware version is pda:lg2 / phone:lg2 / csc:lg2 (tls). Does anyone know how to fix this problem?

8 replies

Userlevel 7
What firmware version is it currently running? You can find this information by going to settings, about phone
Badge +4
Chad Burr wrote:

What firmware version is it currently running? You can find this information by going to setti...

Likely version 4.0.4.
Its running 4.0.4
Badge +4
Cora Hunter wrote:

Its running 4.0.4

I wrote a workaround for this problem that should solve the upgrade issue. Just to confirm, do you have the S2 or the S2x? The reason I ask, is that the software upgrade differs greatly between the S2 and the S2x. The link below is the workaround article I wrote a few months back. http://community.koodomobile.com/koodo/topics/installing_jellybean_4_1_2_when_samsung_kies_wont The latest Odin versions (ODIN v3.07, v3.06, v3.04, v1.85, v1.83) can be found at the link below. Odin version 1.85 works best and is compatible with the S2x. http://forum.xda-developers.com/showthread.php?t=2189539
S 2 X
Badge +4
Cora Hunter wrote:

S 2 X

Ok, then it's just a matter of downloading Odin and then downloading the firmware for your S2x from SamMobile. (You'll have to register with SamMobile, but it's a quick and simple process). The flashing instructions are in the workaround link above. If you run into any problems let us know.
Cora Hunter wrote:

S 2 X

Thanks a million. It worked. Much appriciated★★★
I had the same problem when I tried to upgrade in fact I tried for a week with kies and had the same thing . Just for giggles I tried to do it on my daughters computer and alas I had no problem.So for some reason kies did not like my computer. If you have a second computer I suggest you try that it worked well for me

Reply