Koodo Community

Community

Solved

galaxy ace not texting on data


Minutes*

18 replies

My galaxy ace isn't letting me send text while using data. I've tried taking the sim card and battery out for 15 Miranda it still does it. any ideas what it could be and how it can be fixed, if it can be?
Userlevel 7
This is a design flaw that Samsung chose not to fix. I believe if you turn your wifi on and then off again, it will work
I've tried sending it with the wifi on and off still didn't work. Have to keep my data off. I can send text while using my wifi. Are Samsung doing anything about it?
Christien Garnett wrote:

I've tried sending it with the wifi on and off still didn't work. Have to keep my data off. I can...

Hi Christien - Not likely. The Ace has been out for about 2 years now(give or take) and there has yet to be any word on a fix. Since the ace appears to be the only phone with this issue I doubt they are investing time/money on getting this issue resolved.
Userlevel 7
Christien Garnett wrote:

I've tried sending it with the wifi on and off still didn't work. Have to keep my data off. I can...

Samsung has said that it has no plans on fixing it
Christien Garnett wrote:

I've tried sending it with the wifi on and off still didn't work. Have to keep my data off. I can...

Hey, ive had the same problem.. They say its occurin with a lot if phones when I called in and they are workin on the problem... But for now if u keep usin the wifi and data is on and u turn off the wifi. Ull have to take your battery out...
Userlevel 7
Christien Garnett wrote:

I've tried sending it with the wifi on and off still didn't work. Have to keep my data off. I can...

You do realize you both posted at the same general time. It's possible Ahmad just overlapped. Keep it civil ppl. We have a lot of new eyeballs staring at us.
Other reports have said texting while WiFi is on should work, or switching your phone to 2G mode should allow you to text while using data. What version of Android are you running? Go to settings>About Phone and "Android Version". There's details about the problem and people working on fixes here: http://androidforums.com/samsung-galaxy-ace/406524-gingerbread-broke-sms.html
Userlevel 7
Badge +4
Iglooman wrote:

Other reports have said texting while WiFi is on should work, or switching your phone to 2G mode ...

I can guarantee that setting the phone to 2G will not work with koodo, since koodo does not have a 2G network.
Iglooman wrote:

Other reports have said texting while WiFi is on should work, or switching your phone to 2G mode ...

My brother and I both have Samsung Galaxy Aces. He also has problems with texting while data is activated. No problem when wifi is on though. One trick to help out with the data texting problem is to get a little widget on your homepage that turns the data network on and off. It is a little tedious at times but it's the price you pay for a cheaper phone.
Iglooman wrote:

Other reports have said texting while WiFi is on should work, or switching your phone to 2G mode ...

I heard it was a great phone when I went to buy it.
Iglooman wrote:

Other reports have said texting while WiFi is on should work, or switching your phone to 2G mode ...

I've found it a great phone, although the internal memory is low and I'm starting to hit issues with that, I don't use data, only WIFI, so I haven't hit this issue except for the month Koodo tried to entice me into getting a data package by giving me free data for a month. Sound like you are stuck with a widget to turn off data when you want to text, or be brave and try to upgrade to 2.3.6 like the thread I posted above mentioned near the end. Haven't found confirmation in Canada that it works on the Koodo network though. How old is your phone? If you just got it, you might be able to trade it at the Koodo shop for a different phone without a penalty due to the issue. Overall, for the price, it's a great phone, but now eclipsed by several others, like the Galaxy Ace 2 X offering more memory and Android 4.0 for the same old price of the Galaxy Ace.
Userlevel 6
Badge +4
You can download a widget called DATA ENABLER, this will not solve the issue, but it is a shortcut for you to enable/disable data just by tapping on an icon that you can install on the home screen... will help you to save time...
Userlevel 1
Camilo_A wrote:

You can download a widget called DATA ENABLER, this will not solve the issue, but it is a shortcu...

I also find widgetsoid which does this (providing a data on off toggle widget) and so very much more to be very useful. Instead of just turning something on or off, it's features have features 🙂 Worth a look.
I am running 4,3.4 on my phone.
It is all texts or just picture texts? My wife had a similar problem with her Ace, and I believe the issue was resolved by making sure that the full phone number (eg: 1-902-xxx-xxxx) was put in. Hopefully that helps.
Just to clarify, with koodo you must have data or wifi on just for texting???
Userlevel 7
Bene Smiles wrote:

Just to clarify, with koodo you must have data or wifi on just for texting???

No you don't, you just need to have 3g enabled and be connected. You only need data for mms . 🙂

Reply