Koodo Community

Galaxy 5 neo won't switch on. Battery is fully charged. It was working fine.

Good day one and all.
My phone was working fine this am and now [830pm] it won't switch on from sleep mode. The battery is at 95%. The fixes I have tried are 1) holding power/volume down/home key down for 45 secs; 2) taking the battery out, replacing it and trying (1) again; 3) holding the power key down and plugging into my desktop with USB cord. Nada. Zilch. Any ideas how to get this functioning again or why this even happened.

9 replies

Userlevel 6
Sounds like a hardware fault. Is it still under warranty?
Userlevel 7
Badge +4
Try taking the battery out, hold the power button for one minute, put the battery back in, and then try turning it on.
Hi Cory. Sorry for the delay in replying. I had the same thought re hardware issue. I purchased the phone outright from a Telus store 11 months ago but I am not sure about the warranty. 
Use the reset button and it should work.if not take it to a repair shop.

Hi Allan   tried that and no go
Hi. Robert. ,andy girard try mine and see if that works for u
Thank you Andy tried that as well. Thanks for your help but it looks like I'm headed for the repair shop
Userlevel 6
Robert Yule wrote:

Thank you Andy tried that as well. Thanks for your help but it looks like I'm headed for the repa...

It will have a 1 year warranty, so I would take it in and get it checked/repaired while you still can. 🙂
Badge +4
Can you get into recovery mode?
    Press and hold Volume UP key + Home Key then Press and hold Power key Release all key when Samsung logo appear then you will see Android System Recovery Use Volume UP key and Volume Down key to select Menu Use Power key to Confirm or Execute Menu
Once you're in this menu, you have three options. You can try to reboot the phone from this menu; wipe the cache partition or perform a factory reset, (wipe data /factory reset). If the problem persists, it's likely a hardware issue.