Koodo Community

Community

Solved

Galaxay S2 shows wrong time


My samsung galaxy s2 show time 1 hour behind. I've tried enabling/disabling flight mode. Checked that nothing funny with the time zone setting ect. It is set to get the time from the network & on startup will intially show the correct time before reverting back an hour. The alarm however works to be set to the current correct time... Weird.

6 replies

Userlevel 5
Hm, that's weird. Try restarting the device. By adjusting the time zone settings, you should be able to fix the clock.
Have re-started & pulled the battery about 20 times.
Userlevel 7
Badge +4
Do you have the daylight savings time option checked off if it has one?
Badge +4
Try going back into Settings > Date and time and enable Automatic time zone (Use network-provided time zone). I have no idea where you're located, but for Ontario, I'm showing GMT -4:00 Eastern Daylight Time. Could be a network glitch in your area. Keep us posted.
Userlevel 7
Are you on wifi? Have you set the time.on your router correctly?
Thanks for your help guys. I had tried many of the above suggestions about a month ago with no success. It seems that this time around I was able to manually change the time zone and it has seemed to stay -- previously this wasn't the case. Thanks all! Before the automatic time zone was causing issue and manually changing it didn't work... Works great now.

Reply