Koodo Community

Community

Solved

Differences in signal types??


I have been noticing my cell signal being lower than normal lately (around 3 or even 2 bars) for the past couple of months... normally, say a year ago, im sitting around 4 bars or even 5 bars - in the same location. 

I did some looking around in my phones stats today... and noticed my phone is getting 2 different types of network signals: HSDPA, and UMTS. my signal seems to be overall better when its in UMTS mode, but it switches on its own. when i kick it into airplane mode and back into normal mode... when the signal is at its highest peak, it is using the UMTS mode. when it drops down it seems to be in the other HSDPA mode. 

is there some way i can tell my phone to always look for UMTS type of signal? the HSDPA will get 4 bars sometimes, but this seems more rare. 

I compared with my mothers (also koodo) in the same location, and hers is getting a bit better of a signal, but her connection is HSPA (i think), but hers just remains on the same type of connection constantly. 

my phones battery seems to drain when nothing is running just because its searching for better signal. I notice this alot at work as well. Id like to fix this (without getting a new phone). 

10 replies

Userlevel 7
Badge +4
Go into settings - Mobile Networks - then click on the Network type and switch it to WCDMA only so it's not searching and connecting to a weak LTE signal
Paul "Kid Android" Deschamps wrote:

Go into settings - Mobile Networks - then click on the Network type and switch it to WCDMA only s...

My phone doesnt have this ability... i can find "mobile networks", but the only options within are "use packet data" "data roaming" "access point names" and "network operators"... when i go into network operators, i have it set to "manual" so that way when im near the river i dont start picking up USA signals and getting charged extra. 

Im on 4.0.4 touchwiz based, if that helps.

ETA: If i look within my "network operators" in manual, the options are Koodo, 302610, and EXT. but i dont think i can edit the "koodo" signal, only select it.
Badge +4
Paul "Kid Android" Deschamps wrote:

Go into settings - Mobile Networks - then click on the Network type and switch it to WCDMA only s...

Hi Melanie,

Which phone do you have?

This code works on 'most' Android devices. From your phones' dialpad, dial *#*#4636#*#* (you may need to press Send for it to work) and select 'Phone information'. Scroll down until you see 'Set preferred network type'. Take note of which network type appears there and write it down. Tap on the dropdown menu and scroll through the list until you see 'WCDMA only' or 'WCDMA preferred', select it and press the back key twice to exit the menus.

If the above code doesn't work, this one might: *#*#197328640#*#* I don't know which Android phone you have, some of the older phones use this code. If your phone uses the older code *#*#197328640#*#* your options will be limited to Automatic, GSM_UMTS or UMTS_GSM. In this case, select UMTS_GSM as this setting will take priority over the 2G GSM network, which does not exist on Koodo's network.

Without getting too wordy, UMTS is a 3G technology that makes use of WCDMA and various other components to allow for voice, text and MMS services, but can also carry data at high speeds. HSDPA is part of the 3G network, but is part of the (HSPA) or High Speed Packet Access family that extends and improves the performance of existing 3G mobile networks while utilizing WCDMA protocols.
Paul "Kid Android" Deschamps wrote:

Go into settings - Mobile Networks - then click on the Network type and switch it to WCDMA only s...

I have the samsung captivate glide... this does seem to be helping (i saw both WCDMA only and WCDMA preferred, so i picked the only option)... but, the problem is that it doesnt stick with a reboot. 

Just for fun i did try the GSM only option, and my phone got zero reception... after trying for a bit it got one bar..... so maybe this lousy connection and the CDMA connection have been fighting with each other (the default is GSM/CDMA auto PRL). 

Id like to permanently set this option... if there is a way. I rarely use data except to send/recieve pictures so i probably wouldnt even notice a speed difference.

ETA: Its not even with reboot that it changes... it seems to change back to the HSDPA automatically... after a yet to be determined amount of time... 
Badge +4
Paul "Kid Android" Deschamps wrote:

Go into settings - Mobile Networks - then click on the Network type and switch it to WCDMA only s...

If the phone is set to GSM/CDMA auto (PRL) by default, it means that it auto-switches between GSM and CDMA networks and uses PRL (Preferred Roaming List). There is no way to get the other network settings to stick unless you root the phone and edit the build.prop and that method may not work.

Also, TELUS is in the process of phasing out CDMA network technology across Canada. As a result, you may be in one of the areas affected which could explain the fluctuation in signal. In the article below, TELUS mentions; "In order to ensure these customers do not experience service disruptions, TELUS is proactively contacting them by letter and email to let them know about the upcoming discontinuation of service and the special HSPA upgrade offers available on their account".

http://mobilesyrup.com/2013/10/17/tel...
Paul "Kid Android" Deschamps wrote:

Go into settings - Mobile Networks - then click on the Network type and switch it to WCDMA only s...

I was told, and have read, that CDMA and WCDMA are totally different technologies..... although they have similar letters. i think the CDMA is 2G and WCDMA is 3G... I would imagine theyre keeping the 3G version? Ill check out that link but i cant imagine 3G would be completely outdated already.... 
Badge +4
Paul "Kid Android" Deschamps wrote:

Go into settings - Mobile Networks - then click on the Network type and switch it to WCDMA only s...

Older CDMA networks can incorporate 2G and 3G technology. Your phone is a dual band phone. Newer phones are generally quad band. On your phones' 2.5G side, it can transmit/receive on the following (GPRS/EDGE) frequencies: 850, 900, 1800, and 1900 MHz. Problem with this is that Koodo does not operate a GPRS/EDGE network.

Koodo operates an HSPA network, so your phone is compatible with 3G, UMTS/WCDMA frequencies: 850, 1900, and 2100 MHz. And yes, 3G will be here for awhile until 4G/VoLTE (voice over LTE) supersedes 3G.

The default network setting that appears on your phone, (GSM/CDMA auto PRL), indicates that 3G, UMTS/WCDMA is favoured over CDMA, but will fall back on CDMA if the phone has trouble receiving a 3G, UMTS/WCDMA signal. As mentioned previous, Koodo does not operate a GPRS/EDGE network. So, your phone is essentially searching for a non-existent network which will cause the battery to drain quicker.

By selecting 'GSM only', you're selecting the 2G GSM network which the phone does not have access to. I've experimented with 'WCDMA only', 'WCDMA preferred', (HSUPA) and 'GSM auto PRL' (HSPA) with good signal strength readings, (4 to 5 bars consistently). If you see 'GSM auto PRL' listed, try that setting as well.

Also, there's no need to reboot the phone when changing network modes. This will cause the phone to revert back to its last default network setting. (At time of print of my other post, I didn't have my phone with me to test). Simply back out of the Phone Information menus and take note of the signal strengths and settings. With each of the settings I've mentioned, I've had no issue making/receiving calls, sending/receiving texts or picture messages.
Your putting up your phone bill if you are using your data,you should shut your data off when you are not using it...Go through a Wi-Fi it's cheaper and a lot easier on your poket, and if you are having a problem with the bars on your phone maybe it's because you are to close to a fire wall!!
Evelina Preshyon wrote:

Your putting up your phone bill if you are using your data,you should shut your data off when you...

Not trying to use data at all... im speaking purely about the cell tower signal... i have data switched off on my phone...
Make sure you set your data limit , because if you go over the limit you set you will PAY!

Reply