Koodo Community

Community

Solved

Data not working after changing plans with data?


I have a Samsung Galaxy S4, bought from Koodo. I've been on a $30 plan with no data for almost a year.
Last night, I checked the plans available and realized that I could change my plan to one with 100MB of data for the same price, and so I did.
Unfortunately, even now, using the default APN provided after a factory reset ("Koodo SP"), I cannot connect to use data.

Name: Koodo SP
APN: sp.koodo.com
Proxy: Not set
Port: Not set
Username: Not set
Password: Not set
Server: Not set
MMSC: http://aliasredirect.net/proxy/koodo/mmsc
MMS proxy: 74.49.0.18
MMS port: 80
MMC: 302
MNC: 220
Authentication type: None
APN type: default,mms,supl,hipri
APN protocol: IPv4
APN roaming protocol: IPv4
Enable/disable APN: APN Enabled
Bearer: Unspecified
Mobile virtual network operator type: GID
Mobile virtual network operator value: 4B

Phone/Text works, MMS doesn't.
Mobile Data is toggled on, tried roaming on and off.
WiFi is off.
No VPN is set up.

Although my previous plan did not have data, I did not have the $2 Data Block w/ Pic Msg as a monthly addon.

I've tried various other APNs available, but the phone deletes anything that isn't set a MVNO of "4B". For example, entering "4D4F" as a MNVO and attempting to save it will automatically delete the APN.

Tried adding a proxy of 74.49.0.18:80, didn't work.
Restarted device multiple times.
Toggled airplane mode multiple times.
Tried a factory reset, didn't work.

Is it possible that my data was automatically blocked somehow because I had no data in my previous plan?

11 replies

Userlevel 6
Did you have a Data Block add-on?
Erwin wrote:

Did you have a Data Block add-on?

I did not have the $2 Data Block w/ Pic Msg as a monthly addon.
Userlevel 7
Erwin wrote:

Did you have a Data Block add-on?

Did picture messages ever work for you? That data block is new and may be called something else in your add ons.
Erwin wrote:

Did you have a Data Block add-on?

Picture messages never worked, I didn't have data for them in my previous plan either. They still don't work now that I supposedly have 100MB of data.

I don't have any addons.
Userlevel 7
Erwin wrote:

Did you have a Data Block add-on?

You need to contact koodo and see if a block was added to your account. Picture messages, while requiring data to be on, do not count against data use. So if picture Messaging never worked to begin with then I see a possibility of a data block on Koodos end. Give Tech support a call in the morning, tell them what you've already tried.
Erwin wrote:

Did you have a Data Block add-on?

I don't think I've ever had mobile data on until now because I didn't want to incur any fees, but I'll definitely call Tech support tomorrow.
Userlevel 7
Badge +4
Try pulling the Sim card in and out. Give it a minute.
Goran wrote:

Try pulling the Sim card in and out. Give it a minute.

Didn't work.
Please keep us informed if you find your problem, I'm in the same boat as you.
PROBLEM SOLVED:

It seems that Koodo has a data block implemented on their side (probably to prevent people from incurring extra charges when they had no data), regardless if you have opted for a Data Block in your monthly add-ons.

Just called to have tech support check up on my account, and had it removed.

After following the instruction of removing my battery, 4G is now working.
Userlevel 7
Dan Ho wrote:

PROBLEM SOLVED:

It seems that Koodo has a data block implemented on their side (probably to prev...

Glad you got it working

Reply