Koodo Community

Community

Solved

Change APN to disable Internet while enabling MMS on Samsung Ace 2


Is there any way to change the APN settings on a galaxy Ace 2? I want to change the apn type from "internet + mms" to "mms" so that I can leave data on, receive picture messages, while not using the data for other internet uses. However, on my phone, the options are greyed out, and so I can't edit the apn settings at all. Does anyone have any ideas?

84 replies

Userlevel 7
Using your Picture Messaging without allowing access to Mobile Data by anything else. Brought to you by: The Koodo Mobile Masters with special thanks to Kid Android and Timo Tuokkola. Can you send regular text messages but not picture messages? SIM CARD BASED phones require a data connection in order to send those messages. So if you have data turned off, or blocked, these messages won't go through. "But wait" you say "My plan includes unlimited text and picture messaging. I want to use it but I don't want data because I feel it's too expensive (or whatever)". The Mobile Masters have your solution below. You can enable data by navigating Settings / Wireless and networking / Mobile Network Make sure 'use packet data' or 'enable data' is checked. If you have data blocked by Koodo you'll need to unblock it. You'll have to call customer service to have the block removed. Follow the methods below to ensure data is only available to picture messaging. Setting up A Koodo phone for MMS with no additional Data Access FOR ANDROID DEVICES -=- for iphone 3GS see Note 2 First We need to do a little housekeeping. Navigate to your current messaging app and delete any picuture message you previously tried to send but have failed. Next: Navigate to Settings / Wireless controls / Mobile networks / access point names METHOD 1. Find the Koodo.sp Apn and tap it to open it. Some phones will allow you to edit this APN, for those phones which will not allow you to edit the default APN (I.E the Samsung Galaxy S2x), please skip to Method 2. Tap APN type and change it so it reads only "mms" then tap the menu key and select save APN once saved the 4g indicator should disappear. Please see: Note 1 METHOD 2 You'll be creating two APN's Add the first apn (usually by hitting the menu key and tapping ADD NEW) Note: in the example below please omit the spaces between the http: and the address This is done because some websites shorten URL's Input the following settings (leaving designated fields blank): APN NAME: Koodo (NoData) APN: spp.koodo.com Proxy server: Port: Username: Password: Server: MMSC: Proxy server: Port: MCC : MNC : APN type : default For APN Type we use "default" for this example but if it doesn't work for you, go back and change it to "Internet" Save this entry (usually by hitting the menu key and selecting SAVE) Now create a Second APN using the following settings APN Name: Koodo MMS ALLOW APN: sp.koodo.com Proxy server: 74.49.0.18 Port: 80 Username: Password: Server: MMSC: http: //aliasredirect.net/proxy/koodo/mmsc Proxy server: 74.49.0.18 Port: 80 MCC : 302 MNC : 220 APN type :mms Now save this entry as you did the first. On the list of available Access Point Names you'll notice three (or more) entries. Select the Koodo (NoDATA) APN and make it active (you'll notice you can not choose the Koodo MMS ALLOW entry) Exit the APN menu. Reboot the phone (Shut it off and turn it back on) Turn off your WiFi Open your browser and attempt to access any webpage other than Google (google is normally cached). You should get a message that the page cannot be displayed. Note 1: (For Everyone to read) You'll notice the 3G or 4G data indicator has disappeared leaving only the Signal strength indicator. IF YOU HAD PREVIOUSLY TRIED AND FAILED TO SEND PICTURES IT MAY TAKE A FEW MINUTES FOR THE INDICATOR TO DISAPPEAR. When you do send a picture the Data indicator will re-appear and the picture should be sent. The Same thing will happen when you get a picture message. Note 2: (iPhone 3Gs) Apparently the APN is not easly configurable. You may need to be Jail Broken and download an APP called "Tetherme" which will allow you to edit the APN as per Method 2 (Thanks DJMcPimpin's Sister)
Chad Burr wrote:

Using your Picture Messaging without allowing access to Mobile Data by anything else. Brought to...

I used method 1 and it worked. My question is, will this mean that data will only be access if I send or receive mms? Since the data is on, will other apps be able to access the data? My plan doesn't include data, but it does include mms.
Userlevel 7
Badge +4
Chad Burr wrote:

Using your Picture Messaging without allowing access to Mobile Data by anything else. Brought to...

Just like method 2, method 1 will prevent data being used for anything but mms. Think of the "use packet data" checkbox as the main circuit breaker in your house. What this fix does is turn off the breakers for everything but mms.
Userlevel 7
Chad Burr wrote:

Using your Picture Messaging without allowing access to Mobile Data by anything else. Brought to...

Virtual star to Timo
Userlevel 2
Chad Burr wrote:

Using your Picture Messaging without allowing access to Mobile Data by anything else. Brought to...

I wish I could given one hundred stars.
Userlevel 1
Chad Burr wrote:

Using your Picture Messaging without allowing access to Mobile Data by anything else. Brought to...

Thank-you man I can confirm this works on ace 2x using it now!
Userlevel 4
Chad Burr wrote:

Using your Picture Messaging without allowing access to Mobile Data by anything else. Brought to...

Pretty sure it was confirmed months ago....try not to comment on threads that have been answered months prior.... Unless you have useful information about this issue aside from confirmation...
Chad Burr wrote:

Using your Picture Messaging without allowing access to Mobile Data by anything else. Brought to...

hi I used to have this working fine for the orginal OS for my Samsung S2X phone, now I upgraded a few days ago to jelly bean via the Keis and I had erased the apns so I had to re add, but since the re add I can not send or receive pictures, is there another setting that has changed in Jelly Bean I running 4.1.2 any help be great and they are the exact same settings above I have re checked 4 times
Chad Burr wrote:

Using your Picture Messaging without allowing access to Mobile Data by anything else. Brought to...

I have a Samsung Galaxy S3 and this method does not work i still get data charges. I want data disabled but i want to use my unlimited mms that is included in my plan. I have complained several times that i keep getting charged for background app data while i send an mms and this cannot be turned off (i have set the limit background app data and only update via wifi options to be on) but the android os, gmail, and a few other stock apps you cannot delete still access data in the background even if i turn on data just to send the mms and turn it off once it is sent (the data charge appears as soon as i do this). On the Galaxy S3 it seems you cannot set up a way to use mms without data, Is there another method i could try to accomplish this?
Userlevel 1
Chad Burr wrote:

Using your Picture Messaging without allowing access to Mobile Data by anything else. Brought to...

I think they do this on purpose to get that $5 extra for data used, even its just a few kbs. Ive been happy with koodo since I started Jul 2013, but this is getting out of hand. My wifes phone who has never been charged data now is because of some kbs being used somehow, even with the APN changed and she cant surf. She doesnt want or even use data, doesnt care. But she does like to MMS pictures without having to worry about it
Chad Burr wrote:

Using your Picture Messaging without allowing access to Mobile Data by anything else. Brought to...

Just wanted to let you know that your method works perfectly on my iPhone 6, allowing me to use MMS while blocking data use! Thanks! 🙂
Yes, I have seen this post before, but as I said, the options that are used to edit and add APN's are grayed out and uneditable.
Userlevel 7
You can not add an apn on galaxy ace 2? Can someone confirm please..
Userlevel 1
Chad Burr wrote:

You can not add an apn on galaxy ace 2? Can someone confirm please..

You can add Apn
Userlevel 4
Chad Burr wrote:

You can not add an apn on galaxy ace 2? Can someone confirm please..

I'm sure that was answered....10 months ago.
Userlevel 3
Chad Burr wrote:

You can not add an apn on galaxy ace 2? Can someone confirm please..

I just walked someone through adding a MMS apn so yes it's confirmed
Koodo MMS and MMS are two attempts at tyour method 2. Note that there is no radio option beside the non-default APNs, and that I am long holding the one, and yet there is no option to change to the others as the active access point. There should at least be an unselected radio option.

Userlevel 7
Ok try hitting the menu key on the screen before this
Userlevel 7
I would suggest deleting your attempts and re reading the two APN'S described and try again
Chad Burr wrote:

I would suggest deleting your attempts and re reading the two APN'S described and try again

The APNs were right, but I had to do a trick to be able to switch to them, from the locked-in default
I got it, but it is a ridiculous solution. So, in the list of options when you press the menu key, there is a "reset to defaults" option. After you click that, the radio option by the default APN is unselected - allowing you to choose another one as long as you never select the default, at which point you have to reset it again and start over. This is all to get around the restriction on editing or switching away from the default APN, and seems quite overkill - if someone doesn't know how to edit them, they will probably not be in those settings in the first place. Thank you very much for your help Chad!
Userlevel 7
Ok so it does work for you then yes? Btw did you use default or Internet for the first apn?
Userlevel 7
I think the restriction is there to prevent newbies from accidentally editing themselves off tge network.
Chad Burr wrote:

I think the restriction is there to prevent newbies from accidentally editing themselves off tge ...

But doesn't the "reset to defaults" option cover that well enough?

Reply