Koodo Community

Community

Solved

Cannot Send or Rececive Pictures In Text Messages - Samsung Galaxy S7


A family member in the USA recently upgraded to a Samsung Galaxy S8 on Sprint and he gave me his like-new UNLOCKED Samsung Galaxy S7 as my Galaxy S6 screen decided to stop working a few days ago.

I placed my Koodo Sim Card in the new Galaxy S7 and set the phone up but I cannot seem to send/receive photos via text message.  I can send and receive basic text messages without issue but when I try to receive a picture, it tries to download for awhile and then fails.  When I try to send a picture via text, it just spins and then ultimately fails.

At first, I tried to troubleshoot and found that I had no mobile data at all because the browser said I was offline and Google Play Store said I was offline and had no connection.  (WiFi works fine when I turn it on).  I checked to ensure Mobile Data was turned on (it was) and that Airplane Mode was not turned on (it wasn't).  For good measure, I even tried clearing the cache and even went as far as a complete wipe of the phone and started from scratch.  Still nothing.

I was reading some help websites online and one said to check the Access Point Names (APN) and when I did, the list was empty.  I did a Google search for Koodo's APN settings and found them on a website and plugged them into my APN area under a new entry.  Once I did that, my Mobile Data logo shows a little LTE beside it and I can get websites to load in the browser and Google Play store can download...Facebook and Twitter work, too....but I still can't send or receive pictures in text messages (stock Galaxy Text app "Messages").  I can also make phone calls without issue.

Can anyone help me solve this mystery?  I'm about ready to pull out what little hair I have left!

Thank you very much, in advance.

Jeff

20 replies

Userlevel 7
Can you send us a screen shot of your APN (Access Point Names) settings?


You're probably missing a setting in there.

My guess is your MMSC line is wrong.
Userlevel 7
Badge +4
It should look like this

I sure can!  Here is what I have.  I found it on a website online....


@Robert:  I crearted a new APN using the exact settings you listed above and it won't even get a data connection at all.  With the settings I previously entered, it would say Koodo in the top right corner of the screen and it would show LTE (only when I turned off WiFi for some odd reason) and would get internet connection via mobile data (but not able to send pics via text or receive pics via text).

I switched back to the APN that I was using before that...and it won't connect to the network now either.  (edit:  It turned on LTE again when I deleted the APN with your settings)...but still no picture messaging. 
Userlevel 7
Jeff Docherty wrote:

@Robert:  I crearted a new APN using the exact settings you listed above and it won't...

Jeff, On your APN under APN Type It should read

Default, mms
Jeff Docherty wrote:

@Robert:  I crearted a new APN using the exact settings you listed above and it won't...

Hi Chad,

For MY settings or for the settings Robert posted?
Jeff Docherty wrote:

@Robert:  I crearted a new APN using the exact settings you listed above and it won't...

I changed that setting on my settings...it changed from LTE to 3G above my cellular connection on the homescreen....but still won't send pictures in text messages. 
Userlevel 7
Badge +4
Jeff Docherty wrote:

@Robert:  I crearted a new APN using the exact settings you listed above and it won't...

It'S so weird that if yours match mine it won't work...what if you try APN type : internet + MMS?
Userlevel 2
Jeff Docherty wrote:

@Robert:  I crearted a new APN using the exact settings you listed above and it won't...

Try this, My sister had this issue I hope it is the same
  1. Access ‘Setting menu’ through notification panel (slide down)
  2. Select the gear looking icon or ‘Settings icon’ on the top-right corner of the screen
  3. Navigate to ‘Mobile Networks’ and tap it
  4. When the ‘Data roaming’ is turned on, you must disable by tapping on or off switch
  5. Press the ‘Home key’ to go back to the main screen
If not then try a master reset and reset back up, if you haven't done so.

Jeff Docherty wrote:

@Robert:  I crearted a new APN using the exact settings you listed above and it won't...

No luck, Brent.  Thought we might have had it there...but still no joy. 
Userlevel 7
Badge +4
Jeff Docherty wrote:

@Robert:  I crearted a new APN using the exact settings you listed above and it won't...

Are you using the default messaging app? You can try another one to see if it does anything differently. 

Userlevel 7
Badge +4
I've been having intermittent issues on my LG G6 the past couple days sending and receiving mms so it could be on Koodo's end. Has anyone else here tried to send mms yesterday or today?
A friend gave me the information below and it works!  I can send and receive pictures in text messages now!  The only problem is that I can't send pictures in text messages when WiFi is turned on..only when it's disabled. (So if anyone has a solution for that, it would be awesome!) but I can now send pictures in text after entering the following info in my APN section:

[b]APN Type : default,supl,mms,dun,fota*
Userlevel 7
Jeff Docherty wrote:

A friend gave me the information below and it works!  I can send and receive pictures in tex...

Two questions. When you turn wifi on are you also turning data off somehow? Have you tried another texting app like chomp or gosmspro?
Hi Chad,

All I am doing is pulling down at the top of the screen to get the notification area and I tap the WiFi icon to enable WiFi (same as I've always done on my Galaxy S3 and S6 before this S7)  After a couple of seconds when the WiFi connects, the 3G letters beside the cell connection icon disappear and no mobile data is connected. I can send text messages using words only...can't send/receive picture messages when WiFi is enabled.  When I tap the WiFi icon to disable it, the 3G comes back beside the cell signal icon and I can send and receive picture messages.

I just downloaded Chomp and it works fine.  I could use it...but I'd still love to figure out why this is happening in the stock text app on the Galaxy S7 when it always worked fine on the Galaxy S3 and S6.  I've never heard of this happening whereby turning on WiFi disables mobile data until turned off.

I always left my WiFi enabled 24/7 so it could connect anytime I was around WiFi (plus, if I didn't, I'd forget and be burning my mobile data and wouldn't take long to use up my 2 Gigs per months).  Would anybody really expect to have to turn off their wifi to send or receive a pic on their text messages every time?  I'm convinced it has to be a setting somewhere in the phone as I can't see Samsung suddenly changing how this works when the S7 came out....especially when I've not seen anything about it when I search Google.  I'm sure there it would have caused enough stir to be all over the web if they changed it to work this way in the S7.

Cheers!

Jeff
Userlevel 7
Jeff Docherty wrote:

Hi Chad,

All I am doing is pulling down at the top of the screen to get the notification area an...

If chomp works then the problem is with the messaging app. Goto settings... Applications.... Messaging Clear the cache for messaging You can try clearing the data for it too but that may erase your messages. Not sure. Good luck and let me know
Hi Chad,

Thanks again for the help.  I sincerely appreciate it.

I can't find that option there to clear the cache...but I've already factory reset the phone and wiped it clean three times since I got it to try to resolve the issue.

When the WiFi is switched on, it just disables mobile data....because the 3G icon disappears beside the cell signal bars (triangle) and the 3G symbol reappears when I turn off WiFi.

Never happened with my 3S or 6S.  😞

Userlevel 7
Jeff Docherty wrote:

Hi Chad,

Thanks again for the help.  I sincerely appreciate it.

I can't find that option t...

When you send a MMS the 3G symbol will reappear. Totally normal. On chomp, I love chomp. You can customize just about every aspect of its appearance. IMHO it's a way better experience then the built in message app. I don't know why this is happening to your unit but I'd use chomp even if the phone wasn't having this issue.
Jeff Docherty wrote:

Hi Chad,

Thanks again for the help.  I sincerely appreciate it.

I can't find that option t...

I'm loving Chomp so far!  Thanks for suggesting it, Chad!  I will definitely keep using it!  So many customizable features and it seems very FAST!

The only thing I'm wishing for is a way to know the message has been sent for sure.

In the stock app, a spinning circle would show when sending and then the time would display when the message had been sent.

On Chomp, I don't see any indication that they message has actually been sent.
Userlevel 7
Jeff Docherty wrote:

Hi Chad,

Thanks again for the help.  I sincerely appreciate it.

I can't find that option t...

Check in the settings. There is a confirmation setting that shows checkmarks when messages are sent.

Reply