Koodo Community

Community

Solved

Cannot send and receive picture messages with Samsung Galaxy Ace


So, I'm having trouble sending and receiving picture messages with my Galaxy Ace with a 150mb Data plan. It was solved last time by increasing my text limit. But the thing now is, I have to have the data turned on while the person is sending a picture. If it is not on at that moment, I get a text that says "downloading" but I never get it. But by leaving my data on all the time lets other apps eat away at my limit 😞 I tried created the two APN's, one that says Koodo(NoData) and Koodo MMS ALLOW, and have selected the no data one, but still, my data is just turned on all the time and is being used by other apps. And I can no longer send or receive mms at all! I'm completely at a frustrated loss. Please help fix this 😞

25 replies

Userlevel 7
Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wireless controls / Mobile networks / access point names You'll be creating two APN's Add the first apn (usually by hitting the menu key and tapping ADD NEW) Note: in the example below please omit the spaces between the http: and the address This is done because some websites shorten URL's Input the following settings (leaving designated fields blank): APN NAME: Koodo (NoData) APN: sp.koodo.com Proxy server: Port: Username: Password: Server: MMSC: Proxy server: Port: MCC : MNC : APN type :internet Save this entry (usually by hitting the menu key and selecting SAVE) Now create a Second APN using the following settings APN Name: Koodo MMS ALLOW APN: sp.koodo.com Proxy server: 74.49.0.18 Port: 80 Username: Password: Server: MMSC: http: //aliasredirect.net/proxy/koodo/mmsc Proxy server: 74.49.0.18 Port: 80 MCC : 302 MNC : 220 APN type :mms Now save this entry as you did the first. On the list of available Access Point Names you'll notice three (or more) entries. Select the Koodo (NoDATA) apn and make it active (you'll notice you can not choose the Koodo MMS ALLOW entry) Exit the APN menu. You'll notice the 3G or 4G data indicator has disapeard leaving only the Signal strength indicator. When you do send a picture the Data indicator will re-appear and the picture should be sent. Same when you get a picture message.
Ahmad wrote:

Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wirele...

Like I was saying in my question, I have already done this. My data remains on, and the 3G indicator stays there.
Ahmad wrote:

Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wirele...

Hi, I have an Ace II and I did this as well, but my 4G data indicator has not disappeared.. any advice?
Userlevel 7
Ahmad wrote:

Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wirele...

try editing the original APN if the plugins allows it. change the APN TYPE to mms. save it and select it. delete the two new APN you created earlier
Ahmad wrote:

Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wirele...

when doing this, do you keep packet data checked or unchecked? what about data roaming? and in accounts and sync, do you keep background data and auto sync checked or unchecked?
Ahmad wrote:

Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wirele...

I kept it checked. 🙂
Ahmad wrote:

Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wirele...

Is this counter-intuitive? We are setting up an APN using the APN type "internet", but we want MMS selected, no? As soon as MMS is the type then you can no longer select it from the list of Access points.... Why bother setting up the second APN that can't be selected? I have a plan without data, but unlimited picture messaging, I have the above setting enabled, but it appears that my phone is still using data, for which I am going to be charged for based on my usage stats on Self Serve. How do I get it so picture messaging works, but no other data is being used? Many thanks in advance!
Userlevel 7
Badge +4
Ahmad wrote:

Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wirele...

if you're using the settings above, change the apn on the no data one to spp.koodo.com. (doesn't really matter what you use, just has to be wrong).
Ahmad wrote:

Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wirele...

excellent! thanks. Works like a charm.
Ahmad wrote:

Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wirele...

So that works to send/receive picture messages, however, when I send/receive one it turns on data and updates all things on my phone that need data/wifi, i.e. email. I don't have data plan so it charges me the $5 base rate of flex-data - but obviously I don't want it to do this. What settings need to be set so it only allows picture messages?
Ahmad wrote:

Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wirele...

hi, do you have to have data turned on once you input these settings? also for the NoDATA configuration it automatically sets MCC and MNC to 302 and 220, is this acceptable or should i switch it to 000?
Userlevel 7
Badge +4
Ahmad wrote:

Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wirele...

Mobile data needs to be on. That's your master switch. What we're doing here is fiddling with the individual breakers. MCC must be 302 (Canada) and MNC must be 220 (koodo). They aren't specified because the phone picks them up from the sim automatically.
Ahmad wrote:

Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wirele...

so i enabled data after setting up the apns listed above and then turned off my wifi and my phone began accessing the 4g network. it now shows data usage for facebook, messenger, android, etc. am i going to be charged for that?
Ahmad wrote:

Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wirele...

at first it was on only briefly to receive a picture message but then when i clicked firefox it instantly started accessing 4g
Userlevel 7
Badge +4
Ahmad wrote:

Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wirele...

The instructions above, as written don't work. You need to change the apn for the no data one to something other than sp.koodo.com. I use spp.koodo.com, but it doesn't matter as long as it's wrong. The initial post cannot be edited because people have already commented on it.
Ahmad wrote:

Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wirele...

Thanks very much to the above Ahmad and Timo. This works if you follow the advice from both. No problems whatsoever.
Userlevel 7
Badge +4
On the galaxy ace you can just set the default apn to mms. No other complicated settings required.
Userlevel 7
Badge +4
Timo Tuokkola wrote:

On the galaxy ace you can just set the default apn to mms. No other complicated settings required.

Much easier 😉
Userlevel 7
Timo Tuokkola wrote:

On the galaxy ace you can just set the default apn to mms. No other complicated settings required.

go back to the screen where you added the two new apn and delete them. go to the normal apn and edit the apn type to say mms should solve your problem after a reboot. but if you want to use data for anything else you'll need to go in and remove the mms as type.
Timo Tuokkola wrote:

On the galaxy ace you can just set the default apn to mms. No other complicated settings required.

^ Ahh perfect! Thank you very much sir!
Userlevel 7
Timo Tuokkola wrote:

On the galaxy ace you can just set the default apn to mms. No other complicated settings required.

glad we all could help you. happy picturing
Timo Tuokkola wrote:

On the galaxy ace you can just set the default apn to mms. No other complicated settings required.

Hi prodigy can you tell me how i set the default apn to mms on galaxy ace II x please 🙂
Userlevel 7
Timo Tuokkola wrote:

On the galaxy ace you can just set the default apn to mms. No other complicated settings required.

The ace 2x doesn't allow you to edit the default apn so you'll need to follow the example above.
Timo Tuokkola wrote:

On the galaxy ace you can just set the default apn to mms. No other complicated settings required.

i cant get pictures when someone send me picture it say dowload i press then it say dowloading that it then it is staying like that all the time please help me
Phone Koodo and ask if you accidentally blocked the data, or they did by some God awful chance.....hehehehe. I tried sending a pic text and it got rejected and i remembered i had accidentally blocked it.

Reply