Koodo Community

Community

Solved

Cannot receive MMS on S4


I recently purchased a Galaxy S4 and have been having difficulties receiving MMS. I use the Textra app but was also having difficulties with the default messenger. It allows me to send MMS but often sends multiples of the same image to the recipient. Whenever someone sends me something, it says "Cannot retrieve MMS..." and something about APN settings. MMSC: http://aliasredirect.net/proxy/koodo/mmsc MMS Proxy: 74.49.0.18 MMS Proxy Port: 80 Please help! 😞

6 replies

Userlevel 7
Badge +4
Make sure your APN settings match these and that data is enabled on your device when sending or receiving mms. Name: KOODO APN: sp.koodo.com Proxy: 74.49.0.18 Port: 80 Username: leave blank Password: leave blank Server: leave blank MMSC: http ://aliasredirect.net/proxy/koodo/mmsc MMS Proxy server: 74.49.0.18 MMS Port: 80 MCC: 302 MNC: 220 Authentication type: No set APN type: No set Tap menu key, then tap Save. Make sure the radio button is selected to activate data. The frequencies are compatible so it should work.
Paul "Kid Android" Deschamps wrote:

Make sure your APN settings match these and that data is enabled on your device when sending or r...

I am having this exact same problem. My Koodo SP APN does not let me edit it though so I cannot change anything that you have listed here. The "Proxy" and "Port" on my phone are currently blank, but again they are all greyed out so I cannot edit this APN.
These did not work. 😞 I am still getting the "Cannot retrieve MMS..." notifications.
Userlevel 7
Try changing the APN type to "default,mms"
Userlevel 7
Jonathan I wrote:

Try changing the APN type to "default,mms"

Never thought I'd see the day a MM bump an old thread. Here's to today! LOL 😛
Userlevel 7
Jonathan I wrote:

Try changing the APN type to "default,mms"

Haha I thought it said 6 hours ago. I think I replied before my morning coffee.

Reply