Koodo Community
Solved

Can't Enable Wi-Fi Calling on Pixel 3

  • 7 September 2019
  • 18 replies
  • 1599 views

I switched over to Koodo this week and got a Pixel 3 directly from Koodo. However, I was unable to enable either VoLTE or Wi-Fi Calling on my phone. Despite having "Enhanced 4G LTE Mode" enabled in Mobile network settings, calls would drop to HSPA. Also, whenever I try to enable Wi-Fi Calling I get stuck on this loading screen:



I spoke on the phone with a Koodo rep to explain this issue, and he said that he fixed it by adding VoLTE access (similar to what was done in this thread). While this did fix VoLTE, I am still having the exact same issue enabling Wi-Fi Calling.

Is there anything I can do on my end to fix this issue, or do I have to request another callback from Koodo to get this fixed?
icon

Best answer by rikkster 11 September 2019, 04:37

I came across an article on the TELUS side. Different Pixel, (Pixel 3XL), but what sounds like a similar experience in terms of registering for VoLTE and Wi-Fi calling. There is much discussion over IMS registration. There is a way to check IMS status by entering: *#*#4636#*#* from your phones' dialpad, then tap Phone Information.

IMS status messages:
IMS registration status: available, VoLTE: available, or
IMS registration status: unavailable

It appears that once IMS registration is correctly set up, both VoLTE and Wi-Fi calling are accessible.

Wifi calling on Pixel 3XL won't turn on - see the 'Solved' section
https://forum.telus.com/t5/Mobility-Services/Wifi-calling-on-Pixel-3XL-won-t-turn-on/td-p/93965

Your best option is to request another callback from Koodo to get this matter resolved.
View original

18 replies

Userlevel 7
Badge +4
Was the device sold by Koodo?
Was the device sold by Koodo?
Yes.
Userlevel 7
Badge +4
What was the name of the wifi internet provider of yours?
Telus did identify several ISP that had issue with their wi-fi calling (I assumed Koodo is using the same system). https://www.telus.com/en/bc/support/article/wifi-calling-faq Those are:
  • Access communication
  • Sasktel
  • Bell Aliant
  • Eastlink
  • Xplornet
  • Northwestel
I would suggest you check if your ISP was one of them. If it is, you could follow the instruction in the Telus link and see if it helps.
What was the name of the wifi internet provider of yours?
Telus did identify several ISP that had issue with their wi-fi calling (I assumed Koodo is using the same system). https://www.telus.com/en/bc/support/article/wifi-calling-faq Those are:
  • Access communication
  • Sasktel
  • Bell Aliant
  • Eastlink
  • Xplornet
  • Northwestel
I would suggest you check if your ISP was one of them. If it is, you could follow the instruction in the Telus link and see if it helps.

My ISP is not on that list. Also, when I try to enable Wi-Fi Calling with Wi-Fi disabled and connected to mobile data, I get the same issue. Therefore, I don't believe my ISP is causing this problem.
Badge +4
I came across an article on the TELUS side. Different Pixel, (Pixel 3XL), but what sounds like a similar experience in terms of registering for VoLTE and Wi-Fi calling. There is much discussion over IMS registration. There is a way to check IMS status by entering: *#*#4636#*#* from your phones' dialpad, then tap Phone Information.

IMS status messages:
IMS registration status: available, VoLTE: available, or
IMS registration status: unavailable

It appears that once IMS registration is correctly set up, both VoLTE and Wi-Fi calling are accessible.

Wifi calling on Pixel 3XL won't turn on - see the 'Solved' section
https://forum.telus.com/t5/Mobility-Services/Wifi-calling-on-Pixel-3XL-won-t-turn-on/td-p/93965

Your best option is to request another callback from Koodo to get this matter resolved.

Did you have any luck with this?

 

I recently bought a Pixel 3 from Google, I do have VoLTE working (after asking in Facebook), but no Wifi Calling yet

 

Voice over WiFi unavailable seems suspicious.

Userlevel 7
Badge +4

Did you have any luck with this?

 

I recently bought a Pixel 3 from Google, I do have VoLTE working (after asking in Facebook), but no Wifi Calling yet

 

Voice over WiFi unavailable seems suspicious.

 

Did you have the “VoLTE Access” add-on in your account?

Badge +4

VoLTE should be accessible via your self-serve account, as Dinh mentioned. If I’m not mistaken, you have to call in to have VoWiFi enabled. 

Also, I would suggest choosing a preferred network type that does not include CDMA. This network type is no longer used by Koodo, or the majority of mobile service providers in Canada. Instead, use LTE/UMTS auto (PRL). This will save a little bit of battery as the phones’ radio doesn’t have to hunt for a non-existent network type.

Did you have any luck with this?

 

I recently bought a Pixel 3 from Google, I do have VoLTE working (after asking in Facebook), but no Wifi Calling yet

 

Voice over WiFi unavailable seems suspicious.

 

Did you have the “VoLTE Access” add-on in your account?

Yes, That's the one I got by asking through Koodo's Facebook page.

VoLTE should be accessible via your self-serve account, as Dinh mentioned. If I’m not mistaken, you have to call in to have VoWiFi enabled. 

Also, I would suggest choosing a preferred network type that does not include CDMA. This network type is no longer used by Koodo, or the majority of mobile service providers in Canada. Instead, use LTE/UMTS auto (PRL). This will save a little bit of battery as the phones’ radio doesn’t have to hunt for a non-existent network type.

Yes, I called in but with no luck so far, they asked 2 different tech support guys, both mentioned that my account had everything activated.

Userlevel 7
Badge +4

Did you have any luck with this?

 

I recently bought a Pixel 3 from Google, I do have VoLTE working (after asking in Facebook), but no Wifi Calling yet

 

Voice over WiFi unavailable seems suspicious.

 

Did you have the “VoLTE Access” add-on in your account?

Yes, That's the one I got by asking through Koodo's Facebook page.

 

In your snapshot, you are on LTE network, there isn’t a Wi-fi connection. Have you checked if you enable wifi calling in your phone? was the option there https://www.koodomobile.com/en/help/wifi-calling

 

VoLTE seems to work in your account (in your snapshot)

 

Note that, wifi-calling is only ON when your cellular is weak. (cellular preferred).

Did you have any luck with this?

 

I recently bought a Pixel 3 from Google, I do have VoLTE working (after asking in Facebook), but no Wifi Calling yet

 

Voice over WiFi unavailable seems suspicious.

 

Did you have the “VoLTE Access” add-on in your account?

Yes, That's the one I got by asking through Koodo's Facebook page.

 

In your snapshot, you are on LTE network, there isn’t a Wi-fi connection. Have you checked if you enable wifi calling in your phone? was the option there https://www.koodomobile.com/en/help/wifi-calling

 

VoLTE seems to work in your account (in your snapshot)

 

Note that, wifi-calling is only ON when your cellular is weak. (cellular preferred).

Yes, at that point I just tried registering without WiFi, but I'm at home, with Telus 300Mbps connection, it should be good enough.

 

I have the same problem as the guy that posted the first message, when I tap "On" in the WiFi calling menu, it says "please wait" for a brief time, then I get an infinite spinner.

I don't get asked about the terms and conditions or the code.

 

 

Badge +4

Check the Phone Information menu to see if Voice over WiFi is now available: (*#*#4636#*#*).  Turning ‘Mobile Radio Power’ off will simulate a no-signal situation, but Wi-Fi will still work. Restarting the phone may help. If not, completely power off the phone and power it back on.

I tried, but no luck.

Badge +4

I tried, but no luck.

Some reports suggest putting the phone in Airplane mode, similar to the Mobile Radio Power off method, and re-enabling Wi-Fi. If all else fails, yet another chat with tech support is in order.

Userlevel 7
Badge +4

Before you contact Koodo tech support, I would suggest you reset the network settings and make sure you are not using a Beta version of Android or something. It could be issue with the network profile.

 

If you have an iphone, you could also try to activate wifi calling with the iphone and see if it works.

I want to update that I finally got WiFi Calling working, although I'm not sure what changed, I just tried once again last night and the Website for entering my phone number, receiving the Code and all that appeared.

Either it was a Pixel 3 bug fixed by the latest security update (I installed it some minutes before that), or Koodo fixed something on their end that I wasn't aware of. Or maybe you just need to wait a couple of days since you are added to VoLTE service for enabling WiFi Calling.

Thing is, now is activated and working flawlessly, better than the regular calls.

Thanks!

I want to update that I finally got WiFi Calling working, although I'm not sure what changed, I just tried once again last night and the Website for entering my phone number, receiving the Code and all that appeared.

Either it was a Pixel 3 bug fixed by the latest security update (I installed it some minutes before that), or Koodo fixed something on their end that I wasn't aware of. Or maybe you just need to wait a couple of days since you are added to VoLTE service for enabling WiFi Calling.

Thing is, now is activated and working flawlessly, better than the regular calls.

Thanks!

It worked this time! I'm not sure either if it was the November update or something on Koodo's end, but I was able to go through the Wi-Fi Calling setup page.

 

While I am glad that I have Wi-Fi Calling to fall back on now, it's dumb that Koodo will only enable it when the cellular signal is weak. My son has a Pixel 2XL with Fido, and he can change that setting to prefer either cellular or Wi-Fi for calls. Hopefully Koodo will give us the option to make this choice in the future, as my son has better call quality over Wi-Fi than he does over cellular at home (despite still having an LTE connection).

Reply