Koodo Community

Camera Failure on my S3

  • 10 November 2014
  • 8 replies

My S3 camera won't work as of yesterday and keeps saying "Camera Failed" when I open the feature. Please help!

8 replies

Userlevel 7
Hi Cheryl, What troubleshooting steps have you tried to get the camera working? The very first thing that you should try is to pull the battery out and leave it out for about 30 seconds then put it back in. Test the app again and see if it works. If that doesn't work you can try clearing the cache of the app by going to Settings then Apps then All, find the Camera app and then clear cache and then try again. Hope that helps
Userlevel 7
Badge +4
Shut it down Remove the battery Wait 5 seconds Reinsert Turn it back on Retry camera If it doesn't work navigate to the camera app in settings and clear all the data and cache from the app If it still doesn't work, you'll want to try a factory reset (you'll loose all your data and pictures so be sure to backup) If it still doesn't work and you've had the device for less than one year, contact koodo to arrange warranty service.
Userlevel 5
If you're outside your warranty period and the above solutions to do not resolve the issue. Go to the google play store and download a new camera app. They are free and there's a whole bunch of them out there!
What is the warranty period btw?
Userlevel 5
The warranty of most Koodo devices is 1 year. Only the Alcatel flip model carries a two year warranty.
Userlevel 7
Badge +4
The warranty of most Koodo devices is 1 year. Only the Alcatel flip model carries a two year w...As does the one touch idol x+
Thanks everyone. It worked taking the battery out and restarting.
Userlevel 2
did you notice that you have downloaded some third party camera apps lately ? what are those apps that you have downloaded to use your camera like snapchat and instagram and some others ..some of those apps have issues with new updates ..in my case 7.1.2 with 4S and android 4.4.2 has those issues with bad codes from those apps .. clear data >uninstall>upgrade to new os or reset factory setting is the only answer ..coming from a guy who has tested more than 9 devices across all ios and android platforms ..please be advise, create your backup first