Koodo Community

Community

Solved

Android phone roaming in korea


I was using roaming in japan which worked fine for emergency calls but when I arrived in korea, my phone can't seem to pick up the roaming for calls/ data. This happened after I set my phone on airplane mode before boarding and off the airplane mode after landing in korea. I have a blue studio phone. Do I need to call koodo to reset my phone?

10 replies

Userlevel 7
Goto settings . . wireless and networking... more . . . mobile networks... network selection...manual Your phone will scan for available networks... it takes about two minutes... Your phone will show available /compatible networks Choose one If you don't see any then services may not be available for your device.
Chad Burr wrote:

Goto settings . . wireless and networking... more . . . mobile networks... network selection...m...

I tried exactly what you suggested but no available network is coming up...hard to believe that it won't work in korea though, as it worked fine in japan last week 😞
Userlevel 7
Chad Burr wrote:

Goto settings . . wireless and networking... more . . . mobile networks... network selection...m...

The two countries may use different frequencies . Make sure your network type is set to wcdma /gsm auto as well.
Chad Burr wrote:

Goto settings . . wireless and networking... more . . . mobile networks... network selection...m...

I tried, ,, but my phone is not picking up the available network ...So strange and frustrating!
Userlevel 7
Chad Burr wrote:

Goto settings . . wireless and networking... more . . . mobile networks... network selection...m...

What's the model number of your BLU?
Chad Burr wrote:

Goto settings . . wireless and networking... more . . . mobile networks... network selection...m...

Blue studio 5.5S
Userlevel 7
Badge +4
Chad Burr wrote:

Goto settings . . wireless and networking... more . . . mobile networks... network selection...m...

There are 2 models of your phone with different frequencies, D630U and D630L. If you have the D630U, it would work in Japan, but not Korea. If you have the D630L, it should work in both countries.
Userlevel 7
Chad Burr wrote:

Goto settings . . wireless and networking... more . . . mobile networks... network selection...m...

Beat me to it.. I was researching ! Oh well.
Chad Burr wrote:

Goto settings . . wireless and networking... more . . . mobile networks... network selection...m...

Wow...I do have D630U.....so that's the answer! Thks!!
Userlevel 5
Hey Eunjung,

Do you still need help? You can click here: http://koo.do/1VAwPTc for instructions on how to scan for network manually depending on your Blu Phone model.

Keep us posted!

Thanks

Reply